Incorrect Merchant Descriptors
Incident Report for Bambora North America
Identified
While investigating we discovered that in some instances a different business name was appearing on customer statements. This issue was flagged and a fix was put into place by our upstream processor.

Depending on the card issuer, some cardholders may see a generic descriptor like "Bambora Internet Wholesale" or “Bambora Internet PSP”.

We continue to work with our upstream processor to reduce the occurrences of this issue.
Posted Jan 11, 2024 - 08:53 PST
Investigating
We have identified an issue with our upstream processor where the DBA (Doing Business As) name is not properly appearing on transactions on some accounts.

As a result, the business name may not appear correctly on some cardholder statements.

We will provide updates once the solution has been confirmed.
Posted Jan 04, 2024 - 12:29 PST
This incident affects: Acquirers (First Data).