Merchant Portal not displaying text
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted Mar 11, 2019 - 11:57 PDT
Monitoring
We have resolved the issue and are continuing to monitor.
Posted Mar 11, 2019 - 11:27 PDT
Identified
We have identified the issue and are working towards resolution. At this time if any text elements are failing to load, please refresh the page as this may resolve the issue for you. We will provide an update within the next 30 minutes.
Posted Mar 11, 2019 - 10:52 PDT
Investigating
We have received reports of text elements in the Merchant Portal not displaying correctly. We are investigating the issue and will provide an update within 30 minutes.
Posted Mar 11, 2019 - 10:26 PDT
This incident affected: Merchant Portal.