Customer Care unreachable by phone
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 15:59 PST
Monitoring
Our telephony provider has implemented a fix. We are monitoring for any further issues.
Posted Jan 13, 2021 - 15:37 PST
Update
Our telephony provider is continuing to experience an outage. We are monitoring updates from them closely.
Posted Jan 13, 2021 - 15:19 PST
Identified
Our telephony provider is currently experiencing an outage. We will continue to monitor and provide an update as soon as possible. We are still reachable by email at support.northamerica@bambora.com
Posted Jan 13, 2021 - 14:19 PST
This incident affected: Customer Care.