Global Pay Connection Issues
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted Feb 26, 2021 - 14:18 PST
Monitoring
A fix has been implemented and we are monitoring to ensure resolution. We will provide another update shortly.
Posted Feb 26, 2021 - 10:41 PST
Identified
We are receiving reports of connection issues again resulting in transaction declines for Global Pay merchants. Our team is working to resolve the issue.
Posted Feb 26, 2021 - 09:59 PST
Monitoring
We have been seeing connection issues for Global Pay transactions resulting in transaction declines for Global Pay merchants. A fix has been implemented and we are monitoring to ensure resolution. We will provide another update shortly.
Posted Feb 26, 2021 - 09:46 PST
This incident affected: Acquirers (Global Payments).