Apple Pay Transactions Timeouts
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted Dec 11, 2021 - 16:37 PST
Identified
Our team has identified cause of the timeouts as a third party network issue. They are currently working to resolve the issue.
Posted Dec 11, 2021 - 01:32 PST
Investigating
Our systems are currently having issues completing Apple Pay transactions. Our team is investigating the issue and we will have an update shortly.
Posted Dec 10, 2021 - 22:50 PST
This incident affected: Credit and Debit Card Payments and Acquirers (TD, First Data).