Bambora.com Displaying Error 404
Incident Report for Bambora North America
Resolved
The incident affecting www.bambora.com/en/ca has been resolved.

Please be advised that maintenance is currently being performed on Bambora's Global website, and attempting to access regional pages from bambora.com directly may result in the page failing to load during the maintenance.
Posted May 08, 2019 - 13:33 PDT
Monitoring
The issue impacting this page has been identified. The page should now load without error and we are monitoring for any further issues.
Posted May 08, 2019 - 11:21 PDT
Investigating
We are currently investigating reports that users are seeing an HTTP 404 error when navigating to bambora.com/en/ca. We will provide an update in the next 2 hours.

For users who are trying to use the login option on the bambora.com page, please navigate to web.na.bambora.com instead at this time, as you will be able to log in to your Merchant Portal here.
Posted May 08, 2019 - 09:43 PDT
This incident affected: Merchant Portal.