A fix has been implemented and we are monitoring the results.
Posted Jan 11, 2021 - 14:51 PST
Update
We are continuing to investigate this issue.
Posted Jan 11, 2021 - 14:07 PST
Investigating
We are aware of an issue resulting in password reset emails not being received. We are investigating and will provide an update in the next 30 minutes.