Processing delays
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted Apr 22, 2021 - 09:34 PDT
Update
We experienced a partial system outage today between 2:05 - 5:35 am pst. During this window payment processing and access to the portal was impacted. We have implemented a fix that was successful and we will continue to monitor the results.
Posted Apr 22, 2021 - 06:40 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2021 - 05:52 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 22, 2021 - 05:46 PDT
Investigating
We are currently investigating this issue.
Posted Apr 22, 2021 - 05:22 PDT
This incident affected: Acquirers (TD, First Data, Global Payments) and Credit and Debit Card Payments, Merchant Portal.