Recurring Billing and Batch Processing Issues
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted Mar 02, 2021 - 08:29 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 01, 2021 - 11:40 PST
Investigating
We are currently experiencing issues with our recurring billing and batch processing services. We are investigating the issue and will provide an update shortly.
Posted Mar 01, 2021 - 08:20 PST
This incident affected: Batch and Bank to Bank Payments and Merchant Portal.