Customer Care Tickets Delayed
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted Sep 13, 2019 - 12:16 PDT
Monitoring
The third party has reported a fix and we are monitoring performance.
Posted Sep 13, 2019 - 11:43 PDT
Update
The third party provider is continuing to work on resolving the issue with their platform, we will provide an update within the next two hours or sooner if the situation changes.
Posted Sep 13, 2019 - 10:34 PDT
Identified
Our third party software provider is experiencing an issue with the platform that handles our Customer Care tickets. Responses will be slightly delayed until the issue is resolved.
Posted Sep 13, 2019 - 10:05 PDT
This incident affected: Customer Care.