Merchants may have experienced High Transaction Times
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 14:31 PST
Monitoring
Merchants may have experienced high transaction times for approximately 5 minutes from 12:05 PM PT.

Services have been restored and teams continue to monitor.
Posted Nov 18, 2021 - 12:26 PST
This incident affected: Credit and Debit Card Payments.