Payroll Batch Delays

Incident Report for Bambora North America

Update

We are continuing to investigate this issue.
Posted Jul 06, 2026 - 09:04 PDT

Investigating

We are investigating some batches have not been paid out for payroll.
We are currently working with our partners to identify what has caused this.
Posted Jul 06, 2026 - 08:17 PDT
This incident affects: Batch and Bank to Bank Payments.