Customer Care unreachable by phone
Incident Report for Bambora North America
Resolved
This incident has been resolved. Thank you for your patience.
Posted Aug 26, 2021 - 14:21 PDT
Monitoring
A fix has been implemented and we are once again successfully receiving calls.
Posted Aug 26, 2021 - 12:28 PDT
Update
Our telephony provider has identified the issue and is continuing to work on a resolution as soon as possible. To contact us, please email us at support.northamerica@bambora.com.
Posted Aug 26, 2021 - 11:54 PDT
Identified
Our telephony provider has identified the issue and is working to resolve it as soon as possible. To contact us, please email us at support.northamerica@bambora.com.
Posted Aug 26, 2021 - 11:03 PDT
Investigating
Our Customer Care team is currently unreachable by phones. We are working with our telephony provider to resolve the issue as soon as possible. We are still reachable by email at support.northamerica@bambora.com.
Posted Aug 26, 2021 - 10:25 PDT
This incident affected: Customer Care.