System Outage

Incident Report for Bambora North America

Resolved

This incident has now been resolved
Posted Jun 17, 2026 - 18:17 PDT

Monitoring

The fix has been implemented and we are monitoring the results.
Posted Jun 17, 2026 - 18:08 PDT

Update

We are continuing to work on a fix for the issue.
Posted Jun 17, 2026 - 18:02 PDT

Identified

We have identified the root cause of the issue and are working on implementing a fix.
Posted Jun 17, 2026 - 17:27 PDT

Investigating

We are experiencing a system outage. We are currently investigating, and will provide an update as soon as possible.
Posted Jun 17, 2026 - 17:19 PDT
This incident affected: Credit and Debit Card Payments and Batch and Bank to Bank Payments.