Recurring Billing delayed
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted Mar 30, 2021 - 10:44 PDT
Monitoring
We have completed the outstanding recurring billing transactions that were not complete last night. We continue to monitor for any additional issues.
Posted Mar 30, 2021 - 08:32 PDT
Identified
We have received reports of some recurring billing transactions not completing overnight. We have identified the issue and are in the process of re running these transactions.
Posted Mar 30, 2021 - 07:38 PDT
This incident affected: Credit and Debit Card Payments.