Customer Care unreachable by email
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 07:59 PDT
Monitoring
We are beginning to see emails successfully delivered and will continue to monitor for any changes.
Posted Jul 24, 2024 - 09:51 PDT
Investigating
An outage with an upstream service provider is resulting in inbound emails failing to be delivered. We will provide an update once available.

If you are currently needing support, please reach out by phone at 1-833-226-2672.
Posted Jul 24, 2024 - 09:20 PDT
This incident affected: Customer Care.