Customer Care Email Issue
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted Sep 18, 2019 - 08:49 PDT
Monitoring
A fix has been implemented, and we are currently monitoring the results. We will provide the next update tomorrow morning at 9:00 am PDT.
Posted Sep 17, 2019 - 15:57 PDT
Identified
The issue has been identified and a fix is being implemented. We will provide another update once the issue has been resolved.
Posted Sep 17, 2019 - 15:02 PDT
Update
We are continuing to investigate the issue. We will provide an update within the next hour.
Posted Sep 17, 2019 - 14:44 PDT
Update
We are continuing to investigate this issue.
Posted Sep 17, 2019 - 13:29 PDT
Investigating
We have received notifications that our support email account is experiencing issues. We are currently investigating and will provide updates as they become available. In the meantime, please use support.northamerica@bambora.com or phone in at 1-833-BAMBORA (226-2672) to reach out to our team.
Posted Sep 17, 2019 - 13:28 PDT
This incident affected: Customer Care.