Customer Care unreachable by phone

Incident Report for Bambora North America

Resolved

This incident has been resolved
Posted Jul 09, 2025 - 15:44 PDT

Identified

Customer Care is currently experiencing degraded service and may be unreachable by phone. We are working with our telephony provider to resolve the issue as soon as possible.

We are still reachable by email at support.na@worldline.com.
Posted Jul 09, 2025 - 15:16 PDT
This incident affected: Customer Care.