Email Receipts Delayed
Incident Report for Bambora North America
Resolved
Thank you for your patience, this issue is now resolved.
Posted Nov 12, 2020 - 15:00 PST
Monitoring
A fix has been implemented and we are monitoring the results. Please note, email receipts that were sent prior to 11am pst today may still be delayed. We expect these to send shortly.
Posted Nov 04, 2020 - 12:00 PST
Update
We are continuing to experience an issue that is causing email receipts to be delayed. We will continue to post updates here.
Posted Nov 02, 2020 - 11:03 PST
Identified
We are aware of an issue which is currently causing email receipts to be delayed. We will provide an update once available.
Posted Oct 30, 2020 - 14:01 PDT
This incident affected: Credit and Debit Card Payments.