Processing delays and declines
Incident Report for Bambora North America
Resolved
Incident has been resolved.
Posted Dec 10, 2021 - 08:35 PST
Monitoring
A fix has been implemented and we are monitoring.
Posted Dec 09, 2021 - 05:39 PST
Update
We are continuing to investigate this issue.
Posted Dec 09, 2021 - 05:32 PST
Investigating
We are experiencing processing delays and declines. We are investigating and will post update when we have more information.
Posted Dec 09, 2021 - 05:09 PST
This incident affected: Credit and Debit Card Payments and Acquirers (Global Payments).