Elavon Settlement Delays
Incident Report for Bambora North America
Resolved
We have received confirmation that the pending Elavon transaction settlements have been completed. Elavon merchants impacted will start to receive settlements again.
Posted May 25, 2023 - 11:21 PDT
Identified
We are currently experiencing issues with Elavon transaction settlement. Settlement for transactions from May 21st onward are still pending. A solution has been identified and is currently being implemented. We will update this status once we have additional confirmation of the resolution.
Posted May 25, 2023 - 08:42 PDT
This incident affected: Acquirers (Elavon).