Merchant Portal navigation issues

Incident Report for Bambora North America

Resolved

This incident has been resolved.
Posted Jul 26, 2023 - 09:43 PDT

Update

We are continuing to investigate this issue.
Posted Jul 26, 2023 - 09:41 PDT

Update

We are continuing to investigate this issue.

As a temporary workaround for the issue, some users have reported that the navigation options load successfully when refreshing the page or using an alternative browser.
Posted Jul 26, 2023 - 08:36 PDT

Investigating

We are currently investigating an issue which is preventing some users from being able to access the navigation options in the Merchant Portal. We will provide updates as available.
Posted Jul 26, 2023 - 07:38 PDT
This incident affected: Merchant Portal.