Degraded performance though Chase Paymentech

Incident Report for Bambora North America

Resolved

This incident has been resolved
Posted Sep 11, 2025 - 09:15 PDT

Monitoring

A fix has been implemented and we have seen approval rates return to a normal level.

Our team continues to monitor for any changes.
Posted Sep 11, 2025 - 08:44 PDT

Identified

The issue has been identified and a fix is currently being applied.

We have begun to see approved transactions as we continue to implement the fix
Posted Sep 11, 2025 - 08:30 PDT

Update

Our teams continue to investigate the disruption in service.

We will provide further update as they are available.
Posted Sep 11, 2025 - 08:16 PDT

Investigating

We are currently investigating an issue with transactions failing for merchants processing through Chase Paymentech.

Our technology teams are engaged and reviewing the root cause - Further updates will be provided upon discovery.
Posted Sep 11, 2025 - 07:47 PDT
This incident affected: Acquirers (Chase Paymentech).