Tokenization Services Issues
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted Jan 18, 2021 - 17:20 PST
Monitoring
We experience failures on our tokenization service starting at 11:50AM PST. Incident was resolved at 12:55 PM PST. We currently monitoring.
Posted Jan 18, 2021 - 13:28 PST
This incident affected: Credit and Debit Card Payments.