Payment email receipts not always being received
Incident Report for Bambora North America
Resolved
Payment receipt emails are sending normally again, and any that previously failed to send will go out over the next few hours as the system catches up. We are marking this as resolved.
Posted May 19, 2020 - 11:40 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 19, 2020 - 11:24 PDT
Update
We are continuing to investigate this issue.
Posted May 19, 2020 - 09:35 PDT
Investigating
We are currently looking into reports that email receipts for payments are not always being received by end users and customers. Payments are processing normally at this time.
Posted May 19, 2020 - 08:32 PDT
This incident affected: Credit and Debit Card Payments.