3D Secure failing for Mastercard transactions
Incident Report for Bambora North America
Resolved
No further issues have been found.
Posted Sep 10, 2021 - 15:43 PDT
Monitoring
The new certificates have been imported. We have confirmed Mastercard 3DS approvals.

Teams will continue to monitor
Posted Sep 10, 2021 - 10:09 PDT
Update
This incident has been escalated with Mastercard. An issue with their application has been reported. Mastercard support has advised after the issue is resolved, our request will be processed.
Posted Sep 09, 2021 - 15:28 PDT
Update
Our Master Security Officer has submitted the Certificate Signing Request (CSR) to Mastercard.
We are currently waiting for Mastercard to review our request and issue a new certificate.
Posted Sep 07, 2021 - 14:04 PDT
Update
A Certificate Signing Request (CSR) has been filled out by Bambora Security. It has been forwarded to our Master Security Officer in Stockholm who will submit the request to Mastercard.

There is currently no ETA available.
Posted Sep 07, 2021 - 12:59 PDT
Identified
Mastercard has confirmed that they are no longer supporting SHA1 client certificates. We have requested the new certificates and are currently waiting for a response.
Posted Sep 07, 2021 - 07:43 PDT
Update
Our vendor for 3DS software has advised that new certificates have been issued by Mastercard. We have requested the new CA certificates from Mastercard support.
Posted Sep 03, 2021 - 07:20 PDT
Update
Mastercard support advised their internal teams are still investigating. An estimated time of resolution has not been provided.
Posted Sep 02, 2021 - 15:33 PDT
Update
Teams have identified a possible certificate issue with Mastercard. Mastercard support is investigating.

Further updates will be provided as they become available.
Posted Sep 02, 2021 - 10:07 PDT
Update
A technical bridge has been opened for further troubleshooting. Mastercard has also been engaged to assist in the investigation.
Posted Sep 02, 2021 - 07:59 PDT
Investigating
We are currently not able to connect to Mastercard 3D secure. The connection failure causes all Mastercard transactions to bypass the liability shift for merchants with 3D secure enabled. Our team is investigating the issue and we will provide an update as soon as it is available.
Posted Sep 01, 2021 - 22:19 PDT
This incident affected: Acquirers (TD) and Credit and Debit Card Payments.