Multiple issues with transaction processing
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted May 27, 2022 - 15:01 PDT
Monitoring
We are no longer seeing any processing issues, and are continuing to monitor.
Posted May 25, 2022 - 10:17 PDT
Update
We are continuing to work on a fix for this issue.
Posted May 25, 2022 - 10:15 PDT
Identified
We have identified the issue and have implemented a fix. We are closely monitoring the results.
Posted May 25, 2022 - 09:49 PDT
Update
We are continuing to investigate this issue.
Posted May 25, 2022 - 09:46 PDT
Update
We have identified the issue and are working on a resolution. There is currently an impact to payment profiles, recurring billing, and the merchant portal.
Posted May 25, 2022 - 09:28 PDT
Investigating
We are aware there are multiple issues impacting payment processing. We are aware and working on the issues.
Posted May 25, 2022 - 09:05 PDT
This incident affected: Credit and Debit Card Payments, Batch and Bank to Bank Payments, and Merchant Portal.