Merchant portal access and Transactions failures
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted Feb 10, 2021 - 16:18 PST
Update
Our system are fully operational at this time and we will continue to monitor for any issues.
Posted Feb 10, 2021 - 14:17 PST
Update
We are continuing to monitor for any further issues.
Posted Feb 10, 2021 - 12:44 PST
Monitoring
Our team has identified the issue and implemented a fix. We are currently monitoring the solution.
Posted Feb 10, 2021 - 12:43 PST
Investigating
We are currently having reports of failed transactions as well as merchants having issues accessing our portal.
Our team is investigating the issue and we will have more information shortly. Thank you for your patience.
Posted Feb 10, 2021 - 12:30 PST
This incident affected: Credit and Debit Card Payments and Merchant Portal.