Hosted Checkout experiencing partial degradation of service for some merchants

Incident Report for Bambora North America

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 08:17 PDT

Monitoring

A fix has been implement which should resolve any issues merchants were facing with our Hosted Checkout feature.

We will continue to monitor for any changes.
Posted Mar 13, 2025 - 09:06 PDT

Identified

We have received reports that some merchants are experiencing issues with our Hosted Checkout feature.
If your Hosted Checkout is missing payment fields, please contact our customer support for further guidance on support.na@worldline.com or 1-833-226-2672
Posted Mar 12, 2025 - 08:40 PDT
This incident affected: Credit and Debit Card Payments.