GlobalPay Transactions Failing
Incident Report for Bambora North America
Resolved
This incident has been resolved. All GlobalPay transaction processing has been restored.
Posted Aug 19, 2024 - 07:05 PDT
Investigating
We are currently experiencing issues processing GlobalPay transactions. We are investigating the cause and will update you on the status when more information is available.
Posted Aug 19, 2024 - 05:53 PDT
This incident affected: Acquirers (Global Payments).