Customer Care has limited access the BIC portal
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 11:54 PST
Identified
Our Customer Care team has intermitent issues accesing the BIC portal. A temporary fix has been put in place and the team is monitoring the situation.
Posted Oct 22, 2024 - 14:59 PDT
This incident affected: Customer Care.