Brief Service Interruption
Incident Report for Bambora North America
Resolved
Our team has put in place a fix and the incident has been resolved.
Posted Feb 15, 2024 - 10:31 PST
Update
We are continuing to monitor for any further issues.
Posted Feb 15, 2024 - 10:30 PST
Update
No further issues have been seen since our fix has been implemented.

Our technology team continues to research and monitor this incident closely for any changes.
Posted Feb 14, 2024 - 13:55 PST
Monitoring
We recently experienced a small window of interruption to our payment processing and back office services lasting approx. 12 mins.

This issue was quickly identified and a fix put into place - We have seen processing return to normal at this time.

We are currently monitoring our fix and will provide further updates soon.
Posted Feb 14, 2024 - 12:58 PST
This incident affected: Credit and Debit Card Payments and Merchant Portal.