Intermittent issues with upstream email provider

Incident Report for Bambora North America

Resolved

After no further issues have been identified we are marking this incident as resolved.
Posted Mar 10, 2025 - 08:56 PDT

Monitoring

A fix was implemented and we have seen improvements to successful email deliveries.

We continue to monitor for any changes.
Posted Mar 07, 2025 - 08:38 PST

Investigating

We have identified an issue with our upstream email provider that is causing some operational email to fail to send.

We are currently working to implement a fix which we hope to be applied shortly.
Posted Mar 06, 2025 - 09:03 PST
This incident affected: Merchant Portal.