Batches Showing 'Complete' Prior to Completion

Incident Report for Bambora North America

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 14:08 PST

Investigating

We are aware of a visual bug where a few batch files uploaded display the 'Completed' status before they are completed.
Our teams are working on a fix to this that will be deployed by the end of the week of December 5th.
There are no day-to-day impacts for batch processing.
Posted Nov 27, 2025 - 11:38 PST
This incident affected: Batch and Bank to Bank Payments.