October statements delayed
Incident Report for Bambora North America
Resolved
October statements have now been successfully posted and are available through the Portal.
Posted Nov 09, 2020 - 08:46 PST
Identified
We are experiencing an issue with monthly statements. The monthly statement from October is delayed in posting to the Portal. Our teams are investigating and we expect it to be posted shortly.
Posted Nov 06, 2020 - 09:05 PST
This incident affected: Merchant Portal.