Customer Care unreachable by phone
Incident Report for Bambora North America
Resolved
The issues experienced with our telephony provider have been resolved.
Posted Oct 03, 2024 - 12:32 PDT
Investigating
Customer Care is currently experiencing degraded service accepting calls and are working with our telephony provider to resolve the issue as soon as possible.

We are still reachable by email at support.na@worldline.com.
Posted Oct 03, 2024 - 11:05 PDT
This incident affected: Customer Care.