Increase in declines for Mastercard Apple Pay purchases

Incident Report for Bambora North America

Identified

Our teams have identified the issue and are actively working on the fix. Currently we expect the fix to be deployed within the next few business days.
We will be providing an update once deployed.
Posted Nov 20, 2025 - 10:40 PST

Investigating

Our teams have been alerted to an increase in some Apple Pay Mastercard purchase declines. We are currently investigating the cause and will be providing an update soon.
Posted Nov 20, 2025 - 09:56 PST