Transactions Dropped
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted Mar 22, 2021 - 12:33 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 22, 2021 - 10:04 PDT
Investigating
We have implemented a fix and are monitoring
Posted Mar 22, 2021 - 09:48 PDT
This incident affected: Acquirers (TD, First Data, Global Payments, Elavon, Chase Paymentech, TSYS (Vital), Desjardins) and Credit and Debit Card Payments.