Issues Logging into the Merchant Portal

Incident Report for Bambora North America

Update

We are continuing to investigate the issue. In the meantime we recommend that merchants having issues login using web.na.bambora.com
Posted Aug 26, 2026 - 18:51 PDT

Update

We are continuing to investigate the issue
Posted Aug 26, 2026 - 09:49 PDT

Investigating

We are currently investigating an issue where merchants are experiencing errors when logging into the merchant portal using the updated URL (https://web.bam.shift4api.net/).

For customers who successfully logged in but are experiencing unexpected disconnections from the merchant portal please ensure that you are logged out of the old merchant portal and are only using the updated URL.
Posted Aug 26, 2026 - 08:25 PDT
This incident affects: Merchant Portal.