Our teams have successfully re-populated the majority of the transaction data, and this is now available for viewing. If any further transaction data discrepancies are found, during this time period, please reach out to our Customer Care team with the details: support.na@worldline.com
Posted Jul 29, 2025 - 11:02 PDT
Update
Our technology teams are continuing to work on updating our systems, so that the transaction records during the outage period will be available for viewing. We are processing these updates in batches and we will be sharing further information on our progress.
Posted Jul 22, 2025 - 10:36 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 18, 2025 - 14:13 PDT
Update
Our teams found that during the outage card transactions were successfully processed, however these transaction records were not appearing correctly within our portal. Our technology teams are currently working to update our systems, so that the transaction records will be available within your portal's transaction reporting services. An update will be provided once these changes are complete.
Posted Jul 18, 2025 - 12:53 PDT
Monitoring
We received reports of an outage between 10-11 PM PST last night - July 15th. Our teams are currently investigating the impact of this outage and we will provide a further update in due course.