Customer Care unreachable by phone
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted Feb 08, 2022 - 18:57 PST
Investigating
Customer Care is currently experiencing degraded service. We are working with our telephony provider to resolve the issue as soon as possible. We are still reachable by email at support.na@worldline.com.

We’ll post updates here until the issue is resolved.
Posted Feb 08, 2022 - 18:36 PST
This incident affected: Customer Care.