Incorrect Status Reporting for Bank to Bank payments
Incident Report for Bambora North America
Resolved
This incident has been resolved. The status reporting has been amended and should accurately reflect the batch status'.
Posted May 24, 2023 - 17:00 PDT
Investigating
We are currently experiencing issues with status reporting for Bank to Bank payments. Some transactions are reflected as "in process" when they have been completed. We are investigating the cause and resolution.
Posted May 24, 2023 - 16:29 PDT
This incident affected: Batch and Bank to Bank Payments.