Degraded performance after SSL certification rotation.
Incident Report for Bambora North America
Resolved
No further issues have been seen since our fix was implemented.

We will continue to monitor but consider this incident resolved at this time.
Posted Aug 07, 2024 - 08:20 PDT
Monitoring
We recently identified degraded performance to our platform after rotating our SSL certificates earlier this morning.

A configuration issue was identified and we believe the issues have been resolved - Our Technology team continues to monitor for any changes.


If you have stored our SSL certificates in the past, you can access the updated Certs for na.bambora.com and beansteam.com below:

https://help.na.bambora.com/hc/en-us/articles/29842335082771-August-6th-2024-na-bambora-com-SSL-Cert-Renewal

https://help.na.bambora.com/hc/en-us/articles/29842224974099-August-6th-2024-beanstream-com-SSL-Cert-Renewal
Posted Aug 07, 2024 - 06:42 PDT
This incident affected: Credit and Debit Card Payments.