Recurring Billing Delays
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted Apr 03, 2024 - 08:28 PDT
Monitoring
A fix has been implemented and the Recurring Billing transactions have been processed successfully. We will continue to monitor the results for any further issues.
Posted Mar 27, 2024 - 11:02 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 27, 2024 - 10:27 PDT
Investigating
We are currently experiencing issues with our Recurring Billing transactions. Transactions intended for processing last night did not process. We are currently investigating the issue. We will provide an additional update once more information is available.
Posted Mar 27, 2024 - 08:58 PDT
This incident affected: Credit and Debit Card Payments.