Batch upload issue affecting some merchants

Incident Report for Bambora North America

Update

We've implemented a fix which our teams are closely monitoring to ensure everything is functioning as expected. We will provide an update once the issue is fully resolved.
Posted Aug 28, 2025 - 10:46 PDT

Monitoring

A patch has been applied and our teams are monitoring the results. Additional updates to follow.
Posted Aug 27, 2025 - 16:40 PDT

Update

We have confirmed this is an isolated issue impacting a very limited set of merchants. The underlying cause has been identified, and a fix is currently in development. Additional updates will follow shortly.
Posted Aug 27, 2025 - 12:46 PDT

Identified

We've identified an upload issue impacting a small number of merchants. Our team is actively working on a fix, and we'll provide more updates shortly.
Posted Aug 27, 2025 - 10:31 PDT

Investigating

Our teams have been informed that certain batches are encountering issues while uploading.
We are currently investigating this issue and will update with more information in due course.
Posted Aug 27, 2025 - 08:24 PDT