We momentary had web traffic flip to our secondary site, resulting in momentary interruption of service. We have restored to our primary site and are monitoring.
Posted Jul 30, 2020 - 16:49 PDT
Investigating
We have experienced a system outage. We are currently investigating, and will provide an update within 15 minutes.
Posted Jul 30, 2020 - 16:48 PDT
This incident affected: Credit and Debit Card Payments and Acquirers (TD).