Email Service Degradation
Incident Report for Bambora North America
Resolved
This incident has been resolved.
Posted May 04, 2023 - 15:54 PDT
Monitoring
An issue with an upstream service provider is preventing some system emails such as password resets from being sent. The service provider is actively working on a fix and we will update once resolved.
Posted May 04, 2023 - 15:35 PDT
This incident affected: Merchant Portal and Customer Care.