Recurring Billing - Transaction Delays
Incident Report for Bambora North America
Resolved
The automated Recurring Billing service is working as expected and this incident is being closed.
Posted Mar 07, 2020 - 08:01 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 06, 2020 - 20:41 PST
Update
We are continuing to work on a fix for this issue.
Posted Mar 06, 2020 - 18:43 PST
Update
We are continuing to run our tests and expect them to be completed within the next two hours, at which point an update will be posted.
Posted Mar 06, 2020 - 16:44 PST
Identified
We have identified the cause and are currently running some tests to confirm that functionality is returning to the Recurring Billing service. The next update will be provided by 5pm Pacific / 8pm Eastern time.
Posted Mar 06, 2020 - 14:47 PST
Update
We are continuing to investigate this issue.
Posted Mar 06, 2020 - 13:47 PST
Update
We are continuing to investigate the root cause of the delays in the Recurring Billing processing, the service is now catching up with any missed transactions.
Posted Mar 06, 2020 - 12:42 PST
Update
We are continuing to investigate this issue.
Posted Mar 06, 2020 - 11:45 PST
Update
We are continuing to investigate this issue.
Posted Mar 06, 2020 - 10:43 PST
Update
We are continuing to investigate this issue.
Posted Mar 06, 2020 - 09:47 PST
Investigating
We are currently investigating reports of some transactions through the automated Recurring Billing service being delayed or not processing.

Other services and the APIs are working normally at this time.
Posted Mar 06, 2020 - 09:33 PST
This incident affected: Credit and Debit Card Payments.