Degradation of Service

Incident Report for Bambora North America

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2026 - 12:31 PDT

Investigating

We received reports of an outage around 11:18AM PST.
Our teams are currently investigating the impact of this outage and we will provide a further update in due course.
Posted Jun 25, 2026 - 12:15 PDT
This incident affects: Merchant Portal and Customer Care.